Mit der Null ist das so eine Sache: Manchmal wäre es praktischer – oder zumindest optisch passender –, in einer Excel-Tabelle bei einem Ergebnis „Null“ anstelle der Ziffer „0“ gar nichts zu sehen – oder ein spezielles Zeichen, etwa ein Strich. Mit einem Trick lässt sich das in Excel problemlos erreichen.

Dazu ist lediglich eine „Wenn … dann“-Abfrage in der betreffenden Excel-Zelle nötig. Diese Abfrage überprüft, ob das Ergebnis der bisherigen Formel Null lautet, um dann eine entsprechende Ausgabe zu liefern. Darum erfolgt zunächst die eigentliche Formel-Abfrage. Es folgt das Zeichen, das angezeigt werden soll, wenn das Ergebnis tatsächlich Null ist. Nach dem zweiten Semikolon folgt der Wert, der angezeigt werden soll, wenn das Ergebnis ungleich Null ist. An dieser Stelle muss die bereits am Anfang verwendete Formel wiederholt werden, im folgenden Beispiel „B2-B1+A2″:

=WENN(B2-B1+A2=0;““;B2-B1+A2)

Soll anstellt der Null zum Beispiel ein „*“ gezeigt werden, sieht die Anweisung wie folgt aus:

=WENN(B2-B1+A2=0;“*“;B2-B1+A2)