Wenn in einer Tabelle ermittelt werden soll, wie viele unterschiedliche Werte sie enthält, kommt man mit normalen Formeln nicht weiter. Das klappt nur mit einer Matrix-Formel. Hört sich kompliziert an, ist aber ganz einfach.

Ein Beispiel: Im Zellbereich von A1 bis G9 soll die Anzahl der unterschiedlichen Werte ermittelt werden. Hierzu ins Ergebnisfeld folgende Formel eintragen:

=SUMME(WENN(HÄUFIGKEIT(A1:G9;A1:G9)>0;1))

Wichtig: Da es sich um keine normale Formel, sondern eine Matrix-Formel handelt, die Eingabe nicht mit [Eingabe], sondern mit der Tastenkombination [Strg]+[Shift]+[Eingabe] abschließen. Excel umschließt die Matrixformel daraufhin mit geschweiften Klammern. Wird die Formel geändert, muss sie ebenfalls mit [Strg]+[Shift]+[Eingabe] bestätigt werden.