In kaufmännischen Tabellen kommt es bisweilen darauf an, dass Beträge nur mit zwei Nachkommastellen eingegeben werden dürfen. Damit nicht versehentlich mehr Nachkommastellen eingetragen werden, lässt sich die Eingabe mit einer Gültigkeitsprüfung auf exakt zwei Stellen begrenzen.

Um bereits bei der Eingabe nur Beträge mit maximal zwei Nachkommastellen zu erlauben, sind folgende Schritte notwendig: Die betreffende Eingabezelle oder den Eingabebereich markieren und den Befehl „Daten | Gültigkeit“ bzw. bei Excel 2007/2010 den Befehl „Daten | Datenüberprüfung“ aufrufen.

Dann im Feld „Zulassen“ den Eintrag „Benutzerdefiniert“ auswählen. Ins Feld „Formel“ kommt folgende Formel:

=REST(A1*100;1)=0

Wichtig: Für A1 die erste Zelle des markierten Bereichs einsetzen.

Die Gültigkeitsregel multipliziert den eingegeben Wert mit 100 und berechnet den Rest der Division durch 1. Bei zwei Nachkommastellen gibt es keinen Rest, der Vergleich mit 0 ist dann wahr und der Wert gültig. Werden jetzt drei oder mehr Nachkommastellen eingegeben, erscheint die Warnmeldung „Der eingegeben Wert ist ungültig“.

1 Antwort
  1. Edgar74
    Edgar74 sagte:

    Ggf. sollte die Formel

    =RUNDEN(REST(A1*100;1);1)=0

    verwendet werden, damit auch eine Nachkommastelle eingegeben werden kann (bei mir ergab sich anderenfalls die Fehlermeldung von Excel).

Kommentare sind deaktiviert.