Eigentlich meint es Excel nur gut: Taucht in einer Tabelle eine Division durch Null auf, hat das unweigerlich eine eindeutige Fehlermeldung zur Folge. Durch Null zu teilen ist in der Mathematik nun mal nicht erlaubt. Doch solche Warnhinweise stören, wenn eine Tabelle erst noch mit Werten gefüllt werden will und mangels Eingaben eine Fehlermeldung entsteht.

Wer Belehrungen von Excel vermeiden will, muss zu einem Trick greifen. Kommt die Funktion ISTFEHLER in Kombination mit der WENN-Anweisung zum Einsatz, lassen sich störende #DIV/0-Einblendungen wirkungsvoll verhindern, etwa durch eine Anweisung wie: =WENN(ISTFEHLER(A1/B1);;A1/B1). Für A1 und B1 müssen lediglich die entsprechenden Zellnamen eingetragen werden.

1 Antwort
  1. Schul Psychologe
    Schul Psychologe sagte:

    Hallo,
    Ich will nur Prozentangaben etc. ermitteln. Dabei ist die Null teilweise eine erforderliche Dateneingabe. Wie muss ich die IstWenn-Funktion dann verwenden? Formelbeispiel:=PRODUKT(C12;100/SUMME(C12;E12))
    Haben Sie Dank
    MJBecker

Kommentare sind deaktiviert.