Wenn in Excel-Tabellen keine doppelten Einträge auftauchen dürfen, hilft die Gültigkeitsprüfung. Damit werden neu eingegebene Daten mit vorhandenen Eingaben verglichen – und bei Dopplern ein Warnhinweis eingeblendet.

Stehen zum Beispiel in Spalte A Kundennummern, die nicht doppelt auftauchen dürfen, lassen sich Doppelungen folgendermaßen verhindern: Zuerst die komplette Spalte A markieren, indem auf den Spaltentitel “A” geklickt wird. Dann den Befehl “Daten | Gültigkeit” aufrufen; bei Excel 2007 und 2010 im Menüband “Daten” auf “Datenüberprüfung” und noch einmal auf “Datenüberprüfung” klicken.

Im Listenfeld “Zulassen” den Eintrag “Benutzerdefiniert” wählen und ins Feld “Formel” folgendes eintragen:

=ZÄHLENWENN($A:$A;A1)<2

Danach ins Register “Fehlermeldung” wechseln und die gewünschte Warnmeldung eingeben, etwa “Achtung: Doppelter Eintrag”. Das Dialogfenster mit OK schließen. Wird jetzt in der Spalte A ein bereits vorhandener Datensatz erneut eingetragen, erscheint die Warnmeldung.