In Excel-Tabellen sind Datensätze oft mit einem Datum versehen. In einer Zeile steht zum Beispiel das Eingabedatum, rechts daneben der zugehörige Datensatz. Wenn es darum geht, veraltete Datensätze mit einem Zusatz wie “alt” zu versehen, hilft eine Matrixformel.

Ein Beispiel: In der Spalte A steht in den Zeilen 2 bis 20 das Datum. Rechts daneben stehen in den Spalten B bis D die zugehörigen Datensätze wie Kunden- oder Lieferantennummern. Sollen in der Spalte E alle Einträge mit älterem als das aktuellste Datum mit “Alt” gekennzeichnet werden, muss in Zelle E2 folgende Formel eingegeben werden:

=WENN(A2=MAX(WENN(B$2:B$20&C$2:C$20&D$2:D$20=B2&C2&D2;A$2:A$20;””));””;”Alt”)

Danach den Inhalt der Zelle E2 bis zur Zelle E20 erweitern. Fertig ist die Verfallsdatum-Funktion. Die Matrixformel sucht nach dem aktuellsten Datensatz; dieser bleibt ohne Markierung. Alle anderen (älteren) Datensätze erhalten in der Spalte “E” den Zusatz “Alt”.